Cap 1

 

provides temporary memory for the router's configuration files

*connects the router to network for frame entry and exit

*can be on the motherboard or on a separate module

holds the IOS image

*connects the router to LANs and WANs

 

Which basic components do a router and a standard desktop PC have in common? (Choose three.)

*CPU

hard drive

*input/output interfaces

keyboard

monitor

*system bus

 

The console port can be used for which of the following? (Choose three.)

*debugging

*password recovery

routing data between networks

*troubleshooting

connecting one router to another

 

Which of the following devices are used in the construction of a WAN? (Choose three.)

hubs

*routers

 

*communication servers

transceivers

*modems

multi-port repeaters

 

Which of the following tasks can be accomplished via a management connection on a router? (Choose three.)

*troubleshooting problems

*monitoring the system

capturing LAN data packets

*configuring the router

routing data packets

 

Which ports on Cisco routers can be used for initial configuration? (Choose two.)

Ethernet

*console

*auxiliary

serial

AUI

BRI

 

ABC Company just purchased three new routers to start their company network. Which items are needed to establish a terminal session between a PC and the router for the initial configuration? (Choose three.)

straight-through cable

*terminal emulation software

*rollover cable

*RJ-45 to DB-9 connector

V.35 cable

 

Which of the following descriptions are true regarding the management connections on a Cisco router? (Choose three.)

*They are non-network connections.

They are used to connect the router to the rest of the production network.

They are synchronous serial ports.

*They are used for initial router configuration.

*They are asynchronous serial ports.

They are accessed using their assigned IP address.

 

An internetwork must include which of the following? (Choose three.)

*switching

static addressing

IETF standardization

*dynamic or static routing

*consistent end-to-end addressing

 

A router is composed of many internal components. Which of the following components stores a copy of the router's configuration file?

Metal-Oxide memory

read only memory

flash memory

*non-volatile random access memory

 

Several Ethernet hosts on a LAN need the gateway services of a Cisco 2500 series router. Which of the following would be needed to physically connect a router to all of the hosts on the LAN? (Choose two.)

a crossover cable between the transceiver on a router and a switch

crossover cables between a switch and hosts on a LAN

a straight-through cable between the auxiliary port on a router and a switch

a rollover cable between the console port on a router and a switch

*straight-through cables between a switch and hosts on a LAN

*a straight-through cable between the transceiver on a router and a switch

 

Which of the following are functions of RAM? (Choose three.)

contains startup configuration file

*stores routing table

*holds fast switching cache

retains contents when power is removed

*stores running configuration file

 

Which of the following describes the function of a WAN?

connects peripherals in a single location

connects multiple networks in a single building

provides connectivity on a LAN

*provides connectivity over a large geographic area

 

During the initial configuration of a 2600 series Cisco router, which cable is required for connecting a PC to the console port?

twisted

crossover

*rollover

straight

 

What do routers use to select the best path for outgoing data packets?

ARP tables

bridging tables

*routing tables

switching tables

 

Which of the following are functions of NVRAM? (Choose two.)

stores the routing table

*retains contents when power is removed

*stores the startup configuration file

contains the running configuration file

stores the ARP table

 

Which of the following layers of the OSI model are incorporated in WAN standards? (Choose two.)

*physical layer

application layer

transport layer

*data link layer

session layer

 

Why is a console connection to a router or switch preferred when troubleshooting? (Choose two.)

can be accessed remotely

*does not depend on network services

*displays startup and error messages by default

does not require special components

 

Terminal emulation software, such as HyperTerminal, can be used to configure a router. Which of the following HyperTerminal options shown in the graphic are correctly set to allow configuration of a Cisco router? (Choose three.)

bits per second

*data bits

*parity

*stop bits

flow control

 

What contains the instructions that a router uses to control the flow of traffic through its interfaces?

packet configuration

*configuration files

flash memory

internal components

 

What are the default settings for a serial interface? (Choose three.)

*DTE

DCE

*shutdown

*no IP address

clock rate 56000

encapsulation ARPA

 

A network administrator wants to assure that any password that permits access to the privileged EXEC mode is not shown in plain text in the configuration files. Which set of commands will accomplish this task? (Choose two.)

Router(config)# enable cisco secret

Router(config)# enable cisco

*Router(config)# service password-encryption

*Router(config)# enable secret cisco

Router(config)# encrypt-all cisco

 

Why is it important to create standards for network consistency? (Choose three.)

*reduces network complexity

increases unplanned downtime

*limits unplanned downtime

increases bandwidth by regulating networking performance

*limits events that may impact network performance

 

Select the commands necessary to remove any existing configuration on a router. (Choose two.)

delete flash

*erase startup-config

erase running-config

restart

*reload

delete NVRAM

 

A LAN is to be added to an unused router Ethernet interface. What steps must be performed to configure this interface to allow connectivity to the hosts on this LAN? (Choose two.)

*Enter the command no shutdown.

A password must be set on the interface.

The interface DCE clock rate must be set.

The interface must be configured for virtual terminal access.

*The interface must be configured with an IP address and subnet mask.

The router must be put in setup mode in order for the interface to be configured.

 

Select the commands that will store the current configuration file to a network TFTP server? (Choose two.)

*Router# copy run tftp

Router# copy tftp run

*Router# copy running-config tftp

Router# copy tftp running-config

Router(config)# copy running-config tftp

Router(config)# copy tftp running-config

 

Select the interface descriptions that provide the most appropriate information. (Choose two.)

*circuit number

host IP address

telnet password

number of hops between routers

*purpose and location of the interface

 

Router names are associated with IP addresses. What is the name of the table that is created by this association?

IP table

SAP table

ARP table

MAC table

*HOST table

RARP table

 

The serial connection shown in the graphic needs to be configured. Which configuration commands must be made on the Sydney router to establish connectivity with the Melbourne site? (Choose three.)

*Sydney(config-if)# ip address 201.100.53.2 255.255.255.0

*Sydney(config-if)# no shutdown

Sydney(config-if)# ip address 201.100.53.1 255.255.255.224

*Sydney(config-if)# clock rate 56000

Sydney(config-if)# ip host Melbourne 201.100.53.2

 

Select the recommended locations to save a running-config rile. (Choose three.)

all network hosts

*NVRAM

*floppy disk

*TFTP server

server that is not on the network

 

Select the correct sequence of commands that will configure "Engineering LAN" as the interface description on the Ethernet0 interface.

Router# configure terminal

Router(config)# interface e0 description Engineering LAN

*Router# configure terminal

*Router(config)# interface e0

*Router(config-if)# description Engineering LAN

Router# configure terminal

Router(config)# interface e0

Router(config-if)# interface description Engineering LAN

Router# configure terminal

Router(config)# description Engineering LAN

 

Which statements are true regarding the recommended use of login banners? (Choose two.)

*They should be used to display dated information regarding system changes or maintenance.

*They should be used to display warnings to unauthorized users.

They should be used to display welcome messages prior to login.

They should be seen only by system administrators.

They should provide confirmation of incoming IP addresses.

 

A telnet session can be established when using the IP address of a router but not the name of the router. Which of the following is the most likely cause of the problem?

*an incorrect host table entry

an incorrect ARP table entry

an incorrect routing table entry

an incorrect protocol configured

an incorrect subnet mask

 

Passwords can be used to restrict access to all or parts of the Cisco IOS. Select the modes and interfaces that can be protected with passwords. (Choose three.)

*VTY interface

*console interface

Ethernet interface

secret EXEC mode

*privileged EXEC mode

router configuration mode

 

Which commands display information about the IOS or configuration files stored in router memory? (Choose three.)

Router# show ram

*Router# show flash

Router# show hosts

Router# show history

*Router# show version

*Router# show startup-config

 

Which command turns on a router interface?

Router(config-if)# enable

Router(config-if)# no down

Router(config-if)# s0 active

Router(config-if)# interface up

*Router(config-if)# no shutdown

 

Which command sequence will permit access to all five router virtual terminal lines with a password of cisco?

Router(config-line)#config telnet

Router(config-line)# line vty 0 5

Router(config-line)# password cisco

Router(config)# line vty 0 4

Router(config)# password cisco

*Router(config)# line vty 0 4

*Router(config-line)# password cisco

*Router(config-line)# login

Router(config-line)# config telnet

Router(config-line)# password cisco

Router(config-line)# sessions 0 4

 

What will be the response from the router after the command, "router(config)# hostname portsmouth" is entered?

portsmouth#

*portsmouth(config)#

invalid input detected

router(config-host)#

hostname = portsmouth

portsmouth#

command not recognized

router(config)#

 

What is the default state of the interfaces on a router?

up, line protocol down

down, line protocol down

*adminstratively down, line protocol down

up, line protocol up

 

 

Cap 4

             

Why would an administrator use the Telnet application when troubleshooting a network? (Choose three.)

*It can be used to verify the operation of application layer software between the source and destination.

Telnet can use the ICMP protocol to verify a hardware connection and network layer address.

*It is the most complete testing mechanism available.

*Remote networks may be accessed via a Telnet session for troubleshooting.

Time to Live values are used by Telnet to identify a failure of device between source and destination.

 

What key sequence is used to suspend a Telnet session on a remote router?

Ctrl-Shift-S

Ctrl-Shift-6

*Ctrl-Shift-6, then X

Ctrl-Alt-S

Ctrl-Alt-6

Ctrl-Alt-6, then X

 

A network administrator was called away from the terminal while using Telnet to monitor a remote router. The Telnet session was left connected. If the default Telnet configuration is used, what will the administrator find upon returning 15 minutes later?

The Telnet session entered a "sleep" state and will resume when the spacebar is pressed.

The Telnet session remained connected and is on the same screen it was left on.

The Telnet session suspended itself and will resume when the Enter key is pressed.

*The Telnet session terminated itself after 10 minutes of inactivity.

The Telnet session remained active but now requires the password to be entered again.

 

For which of the following network layer protocols does CDP provide information? (Choose three.)

*IP

RIP

SNMP

*AppleTalk

*IPX

IGRP

 

What is the difference between using the resume command and striking the Enter key when reopening a suspended Telnet session? (Choose two.)

The Enter key requires a connection ID.

The resume command must be executed from the user EXEC mode.

*The resume command requires a connection ID.

The resume command resumes the most recently suspended connection.

*The Enter key resumes the most recently suspended connection.

 

Which of the following is true regarding CDP and the graphic shown?

CDP running on Router D will gather information about routers A, B, C, and E.

*By default, Router A will receive CDP advertisements from routers B and C.

If routers D and E are running different routing protocols, they will not exchange CDP information.

Router E can use CDP to identify the IOS running on Router B.

 

Which command will produce the output shown in the graphic?

show cdp

show cdp neighbors

show cdp neighbors detail

show cdp detail

*show cdp traffic

 

Transmitting type length values (TLVs) inside advertisements is a process used by CDP to provide information about neighboring devices. What information is displayed by these TLVs? (Choose three.)

*interface information of the connected device

all networks connected to the neighboring device

*name of the connected device

routing protocol used on the neighboring device

*holdtime for advertisements

 

Gold is able to ping both Silver and Bronze. A Telnet session between the Gold and Silver router is successful using the command Gold# telnet Silver. However, Gold is unable to establish a Telnet session with Bronze. Which of the following are possible causes for the failure? (Choose three.)

The command was issued from the privileged EXEC mode.

*The vty access has not been set on the remote router.

*The name was incorrectly entered.

The Telnet command was issued from the user EXEC mode.

*The name of the remote router is missing from the host table.

 

What is the purpose of the cdp timers command?

specifies the hold time to be sent in the CDP update packet

resets the traffic counters back to zero

*specifies how often the Cisco IOS software sends CDP updates

deletes and resets the CDP table of information about neighbors

 

Which of the following describes the ping command? (Choose two.)

uses Time to Live values

can be used to verify application layer software

*uses the ICMP protocol to verify reachability

*considered to be a very basic testing mechanism

considered to be the most complete testing mechanism available

 

To obtain CDP information from a Cisco router that is not directly connected to the administrator's console, what must happen?

The source router must send TLV blocks to the remote router.

*The administrator can Telnet to a Cisco device that is connected to the remote router.

The administrator needs to issue the Router# show cdp all to view the entire network CDP advertisements.

The administrator must transmit TTL packets to the remote device and wait for a response.

 

Pings between Atlanta and Dallas are successful. If a hostname table or DNS connection is not available, which command will successfully establish a remote connection from Atlanta to Dallas via Telnet?

Atlanta> connect Dallas

*Atlanta> 197.72.3.2

Atlanta# 206.157.85.1

Atlanta# telnet Dallas

 

How many Telnet sessions can take place simultaneously on a router running a standard edition of the IOS?

4

*5

8

10

15

 

What is the main use of Telnet?

transfer of data between end users

verification of simple connectivity

routing of data packets

*remote connection to network devices

 

Which of the following describes CDP? (Choose two.)

resides at Layer 3 but functions at Layer 2

*obtains information about neighboring devices

*runs on all Cisco equipment and SNAP supported networks

media and protocol dependent

 

An administrator logged into Workstation 2 initiates Telnet sessions to both GAD and BHM from the workstation. What would happen if the Enter key was pressed at the privileged mode prompt after the session with BHM is suspended?

The GAD session would be resumed.

*The BHM session would be resumed.

The GAD session would be terminated.

The BHM session would be terminated.

 

The traceroute command was used to trace the path between routers A and D. What would an output display of three asterisks (***) indicate?

The command was issued from the wrong prompt.

Each datagram was successfully sent.

*One of the routers is unreachable.

There are three hops between source and destination.

 

Which of the following are displayed by the Router# show cdp neighbors command? (Choose three.)

load

*platform

reliability

*holdtime

*local interface

 

An administrator is attempting to enable CDP on the interface of a Cisco router. After issuing the command Router(config-if)# cdp enable, the administrator notices that the interface is still not processing CDP. What might be the problem?

The CDP enable command must be issued from the global mode prompt.

The administrator needed to issue the command Router(config-if)# cdp run.

*CDP has not been configured globally.

The administrator did not manually enter CDP neighbors into the CDP table.

 

An administrator can successfully ping between the Lubbock and Memphis routers. The command Lubbock# telnet Memphis is entered but the Memphis router cannot be reached. What are possible reasons for this failure? (Choose two.)

*The Lubbock router does not have any entries in its host table.

Lubbock is not an entry in the host table of the Memphis router.

*Access to a DNS server is not available.

The hostname command was not configured correctly on the Memphis router.

The hostname command was not configured correctly on the Lubbock router.

 

What command enables CDP on the interface of a router?

*Router(config-if)# cdp enable

Router(config-if)# cdp run

Router(config-if)# cdp start

Router(config-if)# cdp config

 

     

CAP 5

 

The commands shown in the graphic were entered to alter the startup sequence of the router. On the next reload, which IOS will be loaded?

The router will load c2500-js-l.112-26d.

The router will load c2500-d-l.120-9.

The router will load the IOS from ROM.

*The router will boot into ROM monitor mode.

 

Routers have different types of memory. Choose the answer that describes flash memory.

provides working storage

*stores a fully functional IOS image

stores the startup configuration file

initializes the code used to boot the router

 

Routers have different types of memory. Choose the answer that describes NVRAM.

provides working storage

*stores a fully functional IOS image

stores the startup configuration file

initializes the code that is used to boot the router

 

Which command will move configuration files among RAM, NVRAM and a TFTP server?

ping

*copy

move

setup

bootp

backup

 

If a router cannot find a valid configuration file during the startup sequence, what will occur?

The startup sequence will reset.

*The router will enter setup mode.

The startup sequence will halt until a valid configuration file is acquired.

The router will generate a default configuration file based on the last valid configuration.

The router will monitor local traffic to determine routing protocol configuration requirements.

 

What can be learned by issuing the show version command? (Choose three.)

the router hostname

*the current config-register setting

*the location from which the IOS was loaded

the boot system commands configured in NVRAM

*the amount of RAM, NVRAM, and Flash memory in the router

 

Which command will copy an IOS image from a TFTP server to a router?

*Router# copy tftp flash

Router# copy flash tftp

Router(config)# copy tftp flash

Router(config)# copy flash tftp

 

Which of the following can be configured as a source for the IOS image by using the boot system command? (Choose two.)

*TFTP server

HTTP server

Telnet server

*Flash memory

NVRAM memory

 

If the configuration register instructs a router to look for configuration information in NVRAM and no boot system commands exist there, from where will the router boot the IOS?

RAM

ROM

*Flash

EPROM

ROMMON

 

What happens when a router fails to obtain an IOS image from the primary sources during bootup? (Choose two.)

*The router will load a subset of a full IOS version.

*The router will load an IOS image from system ROM.

The router will attempt to reboot two times before failing.

The router will load the last good IOS image from NVRAM.

The administrator will be prompted to load a valid IOS image.

 

Which part of the configuration register indicates the location of the IOS?

the bootstrap

*the boot field

the IOS locator

the system image loader

 

Which command is used to change the order in which the router looks for system bootstrap information?

config-image

config-system

*config-register

config-bootfield

config system bootstrap

 

The router has been configured with a valid configuration file. Which of the following could be a cause for a router not booting normally? (Choose two.)

*The flash image is corrupt.

A console cable is disconnected.

The flash image is located in NVRAM.

The startup configuration file is incomplete.

*The configuration register value is incorrect.

 

Which of the following are steps in saving a router configuration file to a TFTP server? (Choose three.)

Enter configuration mode.

*Verify connectivity to the TFTP server.

*Use the copy running-config tftp command.

Use the copy tftp running-config command.

*Name the configuration file or accept the default name.

 

Which two items below are required by routers in order for them to perform their basic operations? (Choose two.)

a tftp server

*a configuration file

a configuration register file

*an operating system file

a DNS table

 

An IOS image can be copied into flash from a TFTP server. Which of the following statements are true regarding this process? (Choose three.)

*A series of "!'s" are displayed as the image is downloaded successfully to flash.

The copy tftp flash:filename ip address command is used to copy the IOS from the server to flash.

*After the new flash image is downloaded, it is verified.

*A series of "e's" are displayed as the current IOS image is erased from flash.

Flash must be cleared with the erase command prior to beginning the download process.

 

What command can be used in ROM monitor mode to run the IOS image in flash?

rommon1> config-register 0x2102

*rommon1> boot flash:filename

rommon1> xmodem:filename

rommon1> boot system flash:filename

rommon1> reload system flash:

 

The Cisco IOS image naming convention allows identification of different versions and capabilities of the IOS. What information can be gained from the filename c2600-d-mz.121-4? (Choose two.)

The "mz" in the filename represents the special capabilities and features of the IOS.

The file is uncompressed and requires 2.6 MB of RAM to run.

*The software is version 12.1, 4th revision.

The file is downloadable and 121.4MB in size.

*The IOS is for the Cisco 2600 series hardware platform.

 

Where does a router look for boot system statements?

ROM

RAM

*NVRAM

Flash

 

What does a configuration register setting of 0x2102 indicate on a router?

It tells the router to locate and load the IOS from NVRAM.

It tells the router to locate and load the IOS from FLASH.

It tells the router to bypass the configuration in NVRAM.

*It tells the router to look in the startup configuration for boot system commands.

 

 

Cap 6

 

Assuming that the network shown in the graphic is converged and dynamic routing is enabled, which of the following conditions will cause a modification to the Orlando routing table? (Choose two.)

*The device connecting the S0 interface of the Tampa router to the serial link loses power.

*A network administrator shuts down the Orlando router E0 interface.

A DCHP server connected to the Tampa E1 network loses power.

*The IP address of a workstation on the Orlando E0 network is reassigned.

A host on the Orlando E1 network transmits data to a server on the Tampa E1 network.

A Telnet connection to the Orlando router fails.

 

The routers shown in the graphic receive routing updates every 30 seconds by default. Select the commands that were configured on Router2 to achieve this update interval. (Choose two.)

*Router2(config)# router rip

Router2(config)# router igrp 200

Router2(config-router)# network 192.5.5.0 201.100.11.0 210.93.105.0

Router2(config-router)# network 192.5.5.0 255.255.255.0

Router2(config-router)# network 210.93.105.0 255.255.255.0

Router2(config-router)# network 201.100.11.0 255.255.255.0

*Router2(config-router)# network 192.5.5.0

*Router2(config-router)# network 201.100.11.0

*Router2(config-router)# network 210.93.105.0

     

Which of the following factors should be considered when selecting a routing protocol to be implemented in an enterprise network? (Choose three.)

*bandwidth consumption

*router memory requirements

router location

spanning tree size

*router processor capability

flow control capability

 

Given the following commands:

Router(config)# router rip

Router(config-router)# network 192.5.5.0

What can be concluded about the routing processes used on the router? (Choose three.)

A link state routing protocol was used.

*A distance vector routing protocol was used.

*Routing updates will broadcast every 30 seconds.

Routing updates will broadcast every 90 seconds.

*Hop count is the only metric used for route selection.

Bandwidth, load, delay, and reliability are used as metrics for route selection.

 

What is the purpose of a routing protocol?

It is used to build and maintain ARP tables.

It provides a method for segmenting and reassembling data packets.

It allows an administrator to devise an addressing scheme for the network.

*It allows a router to share information about known networks with other routers.

It provides a procedure for encoding and decoding data into bits for packet forwarding.

 

Which type of address does a router use to make routing decisions?

source IP address

source MAC address

*destination IP address

destination MAC address

 

What are some of the advantages of using a link-state routing protocol instead of a distance vector routing protocol? (Choose two.)

The topology database eliminates the need for a routing table.

Frequent periodic updates are sent to minimize the number of incorrect routes in the topological database.

*Routers have direct knowledge of all links in the network and how they are connected.

*After the inital LSA flooding, they generally require less bandwidth to communicate changes in a topology.

Link-state protocols require less router processor power than distance vector protocols.

 

Which two statements describe autonomous systems? (Choose two.)

Interior gateway protocols are used between autonomous systems.

*Exterior gateway protocols are used between autonomous systems.

An autonomous system may be under the control of multiple organizations.

*An autonomous system is identified by a 16 bit number assigned by ARIN.

The autonomous system is identified in the network portion of the IP address.

 

Refer to the network topology shown. Which of the following commands will configure a route to the 172.31.3.0 network that the router will consider to be most reliable?

Montana(config)# ip route 172.31.3.0 255.255.255.0 172.31.4.1

*Montana(config)# ip route 172.31.3.0 255.255.255.0 s1

Utah(config)# ip route 172.31.3.0 255.255.255.0 172.31.2.1

Utah(config)# ip route 172.31.3.0 255.255.255.0 s1

 

Select the statements that describe link-state routing processes? (Choose three.)

*Each router develops its own map of the entire network.

*Routers send triggered updates when changes in the network occur.

*Link-state routing protocols place a higher load on router resources during the routing protocol initialization.

Link-state protocols are more prone to routing loops than distance vector routing protocols.

Networks using link-state routing protocols are slower to reach convergence after changes have occurred than those using distance vector protocols.

     

Why is fast convergence desirable in networks that use dynamic routing protocols?

Routers will not allow packets to be forwarded until the network has converged.

Hosts are unable to access their gateway until the network has converged.

*Routers may make incorrect forwarding decisions until the network has converged.

Routers will not allow configuration changes to be made until the network has converged.

 

Why is it necessary to specify a list of networks when configuring an interior routing protocol?

to tell the router how to reach those networks

to tell the router which attached networks participate in routing updates

*to tell the router which set of metrics to use for the attached networks

to tell the router which routing protocol to use

 

Which of the following statements are true regarding the command ip route 172.16.1.0 255.255.255.0 172.16.2.1? (Choose three.)

*This command is used to set up a static route.

This command is used to set up a default route.

*This command is entered from global configuration mode.

*All packets intended for network 172.16.1.0 will be sent to gateway 172.16.2.1.

All packets intended for network 172.16.2.1 will be sent to gateway 172.16.1.0.

 

How does a router learn about routes to a network? (Choose three.)

*Information is gathered from its own configuration regarding directly connected networks.

Switches forward destination address information to each router.

Hosts communicate destination network information to each router.

*Other routers forward information about known networks.

*Routes are entered manually by a network administrator.

Routes are learned from information gathered from ARP tables.

 

Which of the following are valid static IP routes? (Choose three.)

RouterB(config)# ip route 192.168.5.0 255.255.255.0 S1

*RouterC(config)# ip route 192.168.1.0 255.255.255.0 S1

*RouterA(config)# ip route 192.168.3.0 255.255.255.0 192.168.2.2

RouterB(config)# ip route 192.168.1.0 255.255.255.0 192.168.2.2

*RouterC(config)# ip route 192.168.2.0 255.255.255.0 192.168.4.1

RouterA(config)# ip route 192.168.4.0 255.255.255.0 192.168.2.1

 

If dynamic routing is not configured on a router, how do routing table updates occur?

Link state advertisements are sent from other routers.

*Updates are made to the routing table by the administrator.

Best path information is communicated by network hosts.

The routing table is updated by neighboring routers.

 

Referring to the diagram, which commands will enable hosts on the Idaho E0 network to reach hosts on the E0 network of the Montana router? (Choose two.)

Montana(config)# ip route 172.31.5.0 255.255.255.0 172.31.5.1

*Montana(config)# ip route 172.31.3.0 255.255.255.0 172.31.4.1

Idaho(config)# ip route 172.31.5.0 255.255.255.0 172.31.4.1

*Idaho(config)# ip route 172.31.5.0 255.255.255.0 172.31.4.2

Idaho(config)# ip route 172.31.5.1 255.255.255.0 172.31.4.1

 

The network shown in the graphic is using RIP as the routing protocol. Which of the following is true regarding the network discovery process that will occur for this network? (Choose three.)

*The Palm Beach router will show networks 192.168.7.0 and 192.168.8.0 as directly connected networks.

All of the routers will have direct knowledge of the exact topology of the entire network.

*The Key West router will forward routing table information to the Miami and Palm Beach routers.

The Miami router will learn about network 192.168.1.0 from the Key West router.

*If network 192.168.4.0 becomes unavailable, the Key West router will notify the other routers of this fact in the next update.

 

Given the command, RouterC(config)# ip route 197.5.2.0 255.255.255.0 192.10.1.1, what does the address 192.10.1.1 represent?

the source host

*the next hop router

the outbound interface

the destination network

 

Given the following commands:

Router(config)# router igrp 300

Router(config-router)# network 192.5.5.0

What can be concluded about the routing process on this router? (Choose three.)

*A distance vector routing protocol was used.

A link state routing protocol was used.

Routing updates will broadcast every 30 seconds.

*Routing updates will broadcast every 90 seconds.

Hop count is the metric used for route selection.

*Bandwidth, load, delay and reliability are the metrics used for route selection.

 

Which of the following conditions must be met in order for a network to have converged?

The routers in the network are operating with dynamic routing protocols.

The routers in the network are operating with compatible versions of IOS.

The routers in the network are operating with the same routing tables.

*The routers in the network are operating with consistent routing knowledge.

 

 

Cap.7

 

Refer to the graphic. Assuming default settings are configured, which routing protocol has been configured on the router?

OSPF

RIP

*IGRP

BGP

Static

 

Which of the following methods does split horizon use to reduce incorrect routing information?

Routing updates are split in half to reduce the update time.

*Information learned from one source is not distributed back to that source.

New route information must be learned from multiple sources to be accepted.

The time between updates is split in half to speed convergence.

New route information is suppressed until the system has converged.

 

When does a distance vector routing protocol set a hold-down timer on a route?

when the metric value of the route decreases

*when the route is marked as inaccessible

when the metric value for the route improves

when a regular update is received from a neighboring router

 

When a routing table update is received by a router in a distance vector network, which of the following occurs?

*The hop count metrics for the enclosed routes are incremented.

The update is forwarded to the gateway router for verification.

Path entries are checked for routing loops.

The hop count metrics for the enclosed routes are decremented.

Static routes are updated with the new information.

 

Which of the following is a correct IGRP configuration for the routers shown in the network diagram?

RouterA(config)# router igrp

RouterA(config-router)# network 192.168.0.0

RouterB(config)# router igrp 101

RouterB(config-router)# network 192.168.0.0

*RouterA(config)# router igrp 45

*RouterA(config-router)# network 192.168.1.0

*RouterA(config-router)# network 192.168.2.0

RouterB(config)# router igrp 1

RouterB(config-router)# network 192.168.1.0

RouterB(config-router)# network 192.168.2.0

RouterA(config)# router igrp 1

RouterA(config-router)# network 192.168.2.0

RouterA(config-router)# network 192.168.3.0

RouterB(config)# router igrp 45

RouterB(config-router)# network 192.168.1.0

RouterB(config-router)# network 192.168.2.0

 

What actions will occur after RouterA loses connectivity to network 114.125.16.0? (Choose two.)

*RouterB will include network 123.92.76.0 and 136.125.85.0 in its update to RouterA.

During the next update interval, RouterB will send a RIP update out both ports that includes the inaccessible network.

During the next update interval, RouterC will send an update to RouterB stating that network 114.125.16.0 is accessible in 2 hops.

*Router C will learn of the loss of connectivity to network 114.125.16.0 from RouterB.

RouterB will include network 123.92.76.0 and 136.125.85.0 in its update to RouterC.

 

The graphic shows a network that is configured to use RIP routing protocol. Router2 detects that the link to Router1 has gone down. It then advertises the network for this link with a hop count metric of 16. Which routing loop prevention mechanism is in effect?

split horizon

error condition

hold-down timer

*route poisoning

count to infinity

 

Which command set will stop the IGRP routing process?

RouterB(config)# router igrp 101

RouterB(config-router)#shutdown

RouterB(config)# router igrp 101

RouterB(config-router)#network no 192.168.2.0

*RouterB(config)# no router igrp 101

RouterB(config)# router no igrp 101

 

The command show ip protocols was just issued and the following line was displayed in the output:

Gateway 192.168.2.1 Distance 100 Last Update 00:00:54

When should the next routing table update be received assuming the configuration uses default values?

6 seconds

24 seconds

30 seconds

*36 seconds

90 seconds

 

The following line was displayed in the output of the show ip route command:

192.168.3.0/24 [100/80135] via 192.168.2.2, 00:00:30, Serial0/0

What is the administrative distance of the routing protocol enabled?

30

80

*100

135

80135

 

Which of the following would be the correct command sequence to enable RIP on Router B for all connected networks?

RouterB# router rip

RouterB(router)# network 210.36.7.0

RouterB(router)# network 220.17.29.0

RouterB(router)# network 211.168.74.0

RouterB(config)# router rip

RouterB(config-router)# network 198.16.4.0

RouterB(config-router)# network 211.168.74.0

RouterB(config-router)# network 199.84.32.0

RouterB(config)# configure router rip

RouterB(config-router)# network 210.36.7.0

RouterB(config-router)# network 199.84.32.0

RouterB(config-router)# network 211.168.74.0

RouterB(config)# router rip

RouterB(config-router)# network 198.16.4.0

RouterB(config-router)# network 210.36.7.0

RouterB(config-router)# network 211.168.74.0

*RouterB(config)# router rip

*RouterB(config-router)# network 198.16.4.0

*RouterB(config-router)# network 210.36.7.0

*RouterB(config-router)# network 220.17.29.0

 

The administrator of the network depicted in the graphic would like to decrease the network's convergence time. How can this be accomplished?

disable split horizon on the routers

increase the update interval on the routers

*change the RIP holddown timer to 96 seconds

change the RIP holddown timer to 126 seconds

 

Router B received an interface configuration change. Suddenly, it transmits a new update. Which of the following could have triggered this update? (Choose two.)

*Router B received a configuration change.

Router A sent a message requesting an update.

*Router C came online after Router B sent the RIP update.

Router B received an error message indicating the last update was not received.

 

Which command will display RIP activity as it occurs on a router?

*debug ip rip

show ip route

show ip interface

show ip protocols

debug ip rip config

show ip rip database

 

How would an administrator configure a static route for use if a primary route failed?

configure the route with a metric greater than the default value

configure the route and the router will activate it as needed

configure the route to activate by using the redistribute static command

*configure the route with an administrative distance greater than the default value

 

Which of the following can exist in a distance vector network that has not converged? (Choose three.)

*routing loops

*inconsistent traffic forwarding

no traffic forwarding until system converges

*inconsistent routing table entries

routing table updates sent to wrong destinations

 

Which of the following routes within an autonomous system does not include subnet information?

interior routes

*system routes

border routes

exterior routes

 

The following line was displayed in the output of the show ip route command:

192.168.3.0/24 [100/80135] via 192.168.2.2, 00:00:30, Serial0/0

Based on this information, which routing protocol is enabled?

IP

RIP

*IGRP

IGP

OSPF

 

A router has several classful networks in its routing table. If the router receives packets for a subnet that is not in its routing table and the ip classless command is disabled but a default route is defined, what will happen to the packets?

The packets will be forwarded using the default route.

The packets will be forwarded using a route for one of the major networks.

A nonreachable message will be returned to the source.

*The packets will be discarded.

A default route will be developed by the router.

 

Which of the following functions are performed by a router as routing information travels through the network? (Choose two.)

advertise supported applications

*identify new destinations

calculate packet speed

verify network scalability

*identify invalid networks

 

According to the router output from the show ip route command shown above, which of the following statements are true? (Choose two.)

The metric to network 192.168.8.0 is 24.

*The hop count to a device on network 192.168.8.0 is 2.

The total path cost to network 192.168.4.0 is the default value of 16.

*The logical address of the next router for network 192.168.1.0 is 192.168.3.1.

The devices on network 192.168.5.0 cannot be reached as indicated by the 'C' label.

 

What happens to a static route entry in a routing table when the outgoing interface is not available?

*The route is removed from the table.

The router polls neighbors for a replacement route.

The route remains in the table because it was defined as static.

The router redirects the static route to compensate for the loss of the next hop device.

 

 

Cap 8

 

Which of the following start the test of destination reachability?

*echo request issued by source

echo reply issued by source

echo request issued by destination

echo reply issued by destination

 

Which confirms the availability of a destination? (Choose two.)

The source issues an echo reply after receiving an echo request from the destination.

*The destination returns an exact copy of the data sent by the source.

*The source sends an echo request and receives an echo reply.

The source sends the data to the destination without receiving a reply.

The destination sends an echo request and receives an echo reply.

 

Which ICMP message is sent to a source host when the hop count to the destination is greater than the TTL value of a packet?

echo reply

timestamp reply

destination unreachable

*time exceeded

source quench

 

If workstation 4 sends a message to workstation 2 and it is not delivered, which protocol will report this failure?

Internet Protocol

User Datagram Protocol

Transmission Control Protocol

*Internet Control Message Protocol

 

Which two statements are true regarding ICMP? (Choose two.)

ICMP provides reliability for the TCP/IP protocol stack.

*ICMP is a component of the TCP/IP protocol stack.

*ICMP notifies the sender that data transmission errors have occurred.

ICMP is connection-oriented.

ICMP messages are propagated to all intermediate devices.

 

How does ICMP improve data transfer reliability in IP networks?

Each router in the path reads ICMP packets and uses the information to update routing tables.

ICMP can correct many network problems as they occur.

*ICMP error messages are returned to the sending device when a packet is dropped by a router.

ICMP packets report the intermediary devices that a packet passed through before failure occurred.

 

Workstation 1 sent a data packet to Workstation 4. It never arrived because Fa0/0 interface went down on Router C. How will the devices handle this failure?

Workstation 4 will send an error message to Router C and Workstation 1 that it did not receive the packet.

*Router C will use ICMP to send a message back to Workstation 1 indicating that the packet could not be delivered.

Router C discards the packet without providing notification to any device.

Router C uses ICMP to correct the failure and transmits the data to Workstation

Workstation 1 will use ICMP to correct the problem and then notify Router C to continue the transmission.

 

What does a router do if it is unable to deliver a packet to its destination? (Choose two.)

The router sends the original packet back to the source.

The router keeps the packet in its buffer until the next routing table update.

*The router sends an ICMP "Destination Unreachable" message back to the source.

The router sends out a broadcast message in search of the destination.

*The router discards the original packet.

 

Which devices along a data transmission path are notified by ICMP when delivery failures occur?

*source devices only

destination devices only

intermediary devices

source and destination devices

source, intermediary, and destination devices

 

Which condition could cause a fragmentation needed ICMP destination unreachable message to be sent?

A low bandwidth WAN link has become congested with IP traffic.

*A packet is forwarded from a Token Ring network to an Ethernet network.

A network is not reachable because of faulty routing information.

The address specified by the sending host is nonexistent.

 

When a datagram is processed by a router on the path from source to destination, what happens to the value in the TTL field?"

It is increased by one.

*It is decreased by one.

It stays the same.

It is reset to 0.

Nothing.

 

Which layer protocols provide reliability for IP when needed?

ICMP and ping

RIP and TTL

*upper layer protocols

lower layer protocols

Internet layer protocols

network access layer protocols

 

Which type of message is generated by a host when the ping command is entered?

*ICMP echo request

ICMP echo reply

UDP echo request

UDP error message

 

Which three conditions must be met in order for host to host communication over an internetwork to occur on IP networks? (Choose three.)

The routing protocols configured on the source and destination networks must be the same.

*A default gateway must be properly configured on the hosts and local networks.

*Intermediary devices, such as routers, must be present on the network and have knowledge of how to reach the destination network.

The source and destination host subnet masks must match.

*The IP addresses of the hosts must be in the same network or subnet as their respective gateway devices.

 

 

Cap 10

     

Which statement is true regarding the TCP protocol?

Flow control at the transport layer is provided by adding a sequence number to each segment.

*A sliding window allows for communicating devices to negotiate the amount of unacknowledged data that can be sent.

A window size of 1 would require a receiving device to send ACK 1 after the Segment 1 has been received.

TCP is used by sending hosts to segment large data files prior to transmission while IP is used by receiving host to reassemble the smaller segments.

 

At which point in the transmission process are segments numbered?

when received

when reassembling

*before transmission

while negotiating window size

 

What is the purpose of using port numbers in the transport layer?

to identify the segment as being either TCP or UDP

to provide reliability during data transport

to identify the interface port number used by the router when forwarding data

*to track multiple conversations that occur between hosts

 

Which authority has control over the assignment of port numbers for applications?

IEEE

*IANA

InterNIC

Software Developers Association

 

What is the purpose of Positive Acknowledgment and Retransmission (PAR)?

PAR allows the presentation layer to request that data be resent in a format the destination host can process.

PAR provides a mechanism for the receiving device to request that all segments be retransmitted if one segment is corrupt.

*PAR helps ensure that a number of data segments sent by one host are received by another host before additional data segments are sent.

PAR is used to renegotiate the window size during the synchronization process.

 

Which of the following describe types of port numbers that can be represented in the header of TCP and UDP segments? (Choose two.)

connectionless

*well-known

operational

*dynamic

static

 

Which of the following protocols uses UDP for transport layer services?

SMTP

HTTP

*DNS

FTP

 

What is used by UDP to determine if the data or header has been transferred without corruption?

lower layer protocols

*checksum

PAR

sliding window

acknowledgment and retransmission

IP

 

Which transport layer unit of information places the port number in the header?

data

*segment

packet

frame

bit

 

How are originating source port numbers assigned during the data encapsulation process?

assigned manually by the user when starting the application

*assigned dynamically by the source host

assigned by the routing protocol during the lookup process

assigned by the destination host during session negotiation

 

Which of the following are functions of the TCP protocol? (Choose three.)

translation of data

*synchronization

path determination

*flow control

data representation

*reliability

 

Which of the following describes a type of denial of service attack designed to exploit the normal function of the TCP three-way handshake?

*A host sends a packet with a spoofed source IP address.

A host sends a packet with an incorrect destination IP address.

A source sends a packet containing a garbled header.

A host sends an oversized packet that fills the memory buffers of the destination host.

A host sends a packet that contains a virus.

A host sends a packet that contains a worm.

     

During the encapsulation process, in which order are the IP address, MAC address, and port number assigned when the router is establishing communication with the TFTP server?

IP address, MAC address, port number

MAC address, IP address, port number

*port number, IP address, MAC address

port number, MAC address, IP address

 

Why is TCP considered a connection-oriented protocol?

It establishes a virtual connection between hosts using a two-way handshake.

It uses IP to guarantee delivery of packets between hosts.

*It requires hosts to go through a synchronization process prior to data transmission.

It creates a connection that depends on application layer protocols for error detection.

 

What is the purpose of the three-way handshake that occurs between hosts using TCP as the transport layer protocol?

to determine the number of packets that can be sent before an acknowledgment is required

to allow a host to forward data to a router

*to establish a round trip connection between sender and receiver before data is transferred

to provide a mechanism for data encryption and compression

 

When a host receives a data segment, what allows the host to determine which application should receive the segment?

IP source address

IP destination address

PAR

sliding window

*port number

SYN packet

 

What type of segment and data is shown in the graphic?

a UDP segment carrying e-mail traffic

a TCP segment carrying FTP traffic

an IP segment carrying FTP traffic

a UDP segment carrying web traffic

*a TCP segment carrying web traffic

an IP segment carrying e-mail traffic

 

Which of the following would an administrator do to defend against a denial of service SYN flooding attack? (Choose two.)

Hide the source of incoming IP addresses.

*Decrease the connection timeout period.

Synchronize all host communication.

*Increase the connection queue size.

Flood the network with false SYN requests.

 

What is used by both TCP and UDP when creating a segment?

IP address

MAC address

IPX address

*socket or port number

acknowledgment number

sequence number

 

Which of the following describes how TCP adds reliability to communication? (Choose two.)

*Hosts using TCP set up virtual circuits at the beginning of the transmission using the three-way handshake.

Hosts using TCP set the error-checking frequency at the beginning of the transmission and maintain this frequency for the duration.

*The receiving host acknowledges that it has received the expected number of segments and requests additional data.

The receiving host acknowledges any incorrectly received data and requests retransmission of damaged or missing bytes.

 

Which address is dynamically assigned by the source host when forwarding data?

destination IP address

destination port number

default gateway address

source IP address

*source port number

     

What does TCP use to ensure reliable delivery of data segments?

upper layer protocols

lower layer protocols

*sequence numbers

port numbers

 

A computer programmer is developing software that requires a reliable stream of data. Which protocol can be used in the software design to eliminate the need for building error detection and recovery into the application program?

*TCP

IP

ICMP

UDP

HTTP

 

Which of the following determines the amount of data that can be sent without an acknowledgment when sending a TCP segment?

segment number

priority number

*window size

value in the length field

value in the port field

acknowledgment number

 

Cap 11

 

Create a standard ACL that will deny traffic from 192.5.5.25 to the 210.93.105.0 network but will allow traffic from all other hosts. (Choose two.) Wrong

Router(config)# access-list 22 deny 192.5.5.25 0.0.0.0

Router(config)# access-list 22 deny host 192.5.5.25 0.0.0.0

Router(config)# access-list 22 permit any any

*Router(config)# access-list 22 deny 192.5.5.25 0.0.0.0

*Router(config)# access-list 22 permit any

*Router(config)# access-list 22 deny host 192.5.5.25

*Router(config)# access-list 22 permit any

Router(config)# access-list 22 deny 192.5.5.0 0.0.0.255

Router(config)# access-list 22 permit any

 

Create an access list that will prevent only the host 192.5.5.148 from accessing a web site located at 210.93.105.50.

access-list 10 deny tcp host 192.5.5.148 host 210.93.105.50 eq 80

access-list 10 permit tcp any any

access-list 10 deny tcp 192.5.5.148 0.0.0.0 210.93.105.50 0.0.0.0 eq 23

access-list 10 permit tcp any any

*access-list 100 deny tcp 192.5.5.148 0.0.0.0 210.93.105.50 0.0.0.0 eq 80

*access-list 100 permit tcp any any

access-list 100 deny tcp 192.5.5.148 0.0.0.255 210.93.105.50 0.0.0.255 eq 80

access-list 100 permit tcp any any

access-list 100 deny tcp host 192.5.5.148 255.255.255.255 210.93.105.50 255.255.255.255 eq 80

access-list 100 permit tcp any any

 

Which statement is true regarding wildcard masks?

The wildcard mask and subnet mask perform the same function.

The wildcard mask is always the inverse of the subnet mask.

*A "0" in the wildcard mask identifies IP address bits that must be checked.

A "1" in the wildcard mask identifies a network or subnet bit.

 

The following commands were entered on a router:

Router(config)# access-list 2 deny 172.16.5.24

Router(config)# access-list 2 permit any

What can be concluded about this set of commands?

The access list statements are misconfigured.

All nodes on 172.16.0.0 will be denied access when these statements are applied.

*The default wildcard mask, 0.0.0.0 is assumed.

The default wildcard mask 255.255.255.255 is assumed.

 

ACL statements operate in sequential, logical order. If a condition match is true, the rest of the ACL statements are not checked. If all of the ACL statements are unmatched, what happens to the packet?

The packets will be placed in a buffer and forwarded when the ACL is removed.

The packets will be sent to the source with an error notification message.

The implicit permit any statement placed at the end of the list will allow the packets to flow through uninhibited.

*The implicit deny any statement placed at the end of the list will cause the packets to be dropped.

     

Select the statements that describe ACL processing of packets. (Choose three.)

*An implicit deny any rejects any packet that does not match any ACL statement.

*A packet can either be rejected or forwarded as directed by the statement that is matched.

A packet that has been denied by one statement can be permitted by a subsequent statement.

A packet that does not match the conditions of any ACL statements will be forwarded by default.

*Each statement is checked only until a match is detected or until the end of the ACL statement list.

Each packet is compared to the conditions of every statement in the ACL before a forwarding decision is made.

 

Choose the command that will correctly configure a standard ACL.

Router# access-list 10 permit any

Router# access-list 101 permit any

*Router(config)# access-list 10 permit any

Router(config)# access-list 101 permit any

Router(config)# access-list 10 permit any any

 

Choose the commands that will correctly configure a standard ACL. (Choose two.)

*Router(config)# access-list 97 permit host 192.5.5.1

*Router(config)# access-list 32 permit 210.93.105.3 0.0.0.0

Router(config)# access-list 148 permit 201.100.11.2 0.0.0.0

Router(config)# access-list 107 permit host 192.5.5.1 213.45.27.0 0.0.0.255 eq 23

Router(config)# access-list 10 permit tcp 192.5.5.1 0.0.0.255 201.100.11.0 0.0.0.255 eq 80

     

Select the commands that will apply the ACL in the diagram to filter traffic going to the 192.168.2.0 network.

Router1# configure terminal

Router1(config)# access-list 10 in E0

Router1(config)# interface ethernet 0

Router1(config-if)# access-list 10 in

Router2(config)# interface s1

Router2(config-if)# ip access-group 10 out

*Router2(config)# interface ethernet 0

*Router2(config-if)# ip access-group 10 out

Router1(config)# interface ethernet 0

Router1(config-if)# ip access-group 10 out

Router2# configure terminal

Router2(config)# access-group 10 out

 

Which of the following parameters can ACLs use to filter traffic? (Choose three.)

packet size

*protocol suite

*source address

*destination address

source router interface

destination router interface

 

Which of the following matches an ACL identification number with the correct protocol?(Choose three.)

0 - standard IP

*99 - standard IP

*100 - extended IP

210 - extended IP

678 - extended IPX

*888 - standard IPX

 

Select the correct statements about extended ACLs. (Choose two)

Extended ACLs use a number range from 1-99.

Extended ACLs end with an implicit permit statement.

*Extended ACLs evaluate the source and destination addresses.

*Port numbers can be used to add greater definition to an ACL.

Multiple ACLs can be placed on the same interface as long as they are in the same direction.

 

Which of the following are reasons to use ACLs? (Choose three.)

*to provide a basic level of security for network access

to speed up network performance by filtering priority packets

*to preserve bandwidth by providing a mechanism for traffic flow control

to decide which packets are forwarded or blocked at the router console port

*to screen certain hosts to either allow or deny access to part of a network

to allow all packets passing through the router access to all parts of the network

 

A router that has two Ethernet interfaces and one serial interface is configured to route both IP and IPX. What is the maximum number of IP ACLs that can be configured to filter packets on this router?

1

2

3

*6

12

 

The router IOS tests each condition statement in an ACL in sequence. Once a match is made, which of the following occurs? (Choose two.)

The entire ACL must be deleted and recreated.

*The accept or reject action is performed.

The packet is forwarded to the next hop.

*The remaining ACL statements are not checked.

The router goes through the list again to verify that a match has been made.

 

Which statements are true regarding the meaning of the access control list wildcard mask 0.0.0.7? (Choose two.)

The first 29 bits of a supplied IP address will be ignored.

*The last three bits of a supplied IP address will be ignored.

The first 32 bits of a supplied IP address will be matched.

*The first 29 bits of a supplied IP address will be matched.

The last four bits of a supplied IP address will be matched.

 

Assuming the ACL in the graphic is correctly applied to an interface, what effect will the ACL have on network traffic?

All traffic to network 172.16.0.0 will be denied.

All TCP traffic will be permitted to and from network 172.16.0.0.

*All telnet traffic from the 172.16.0.0 network to any destination will be denied.

All port 23 traffic to the 172.16.0.0 network will be denied.

All traffic from the 172.16.0.0 network will be denied to any other network.

 

Assuming the ACL in the graphic is correctly applied to an interface, what effect will this ACL have on network traffic?

*Host 192.168.15.4 will be denied ftp access to any destination, but will be permitted all other access.

All ftp traffic to host 192.168.15.4 will be denied.

All traffic from that interface will be denied.

No traffic will be denied because a "permit" statement does not exist in this ACL.

 

An access list has been created that will deny the host 204.204.7.89 access to an ftp server located at 196.6.13.254.

access-list 111 deny tcp 204.204.7.89 0.0.0.0 196.6.13.254 0.0.0.0 eq 21

access-list 111 permit tcp any any

Which of the following groups of commands will place this ACL in the proper location?

Router2(config)# interface s0/0

Router2(config-if)# ip access-group 111 in

Router2(config)# interface fa0/0

Router2(config-if)# ip access-group 111 out

*Router2(config)# interface fa0/0

*Router2(config-if)# ip access-group 111 in

Router3(config)# interface fa0/0

Router3(config-if)# ip access-group 111 in

Router3(config)# interface s0/1

Router3(config-if)# ip access-group 111 out

Router3(config)# interface fa0/0

Router3(config-if)# ip access-group 111 out