Tutorial
Generalità sul tutorial

In questo tutorial dovrai contare sull'abilità di base appresa nelle lezioni e creerai un opera un po' più complessa. Creerai una home page per una compagnia di magneti per frigoriferi che rappresenta simboli animati, bottoni animati, e un modo per memorizzare gli indirizzi email.

Riuscire a capire e ad avvantaggiarsi della potenza dei simboli è importantissimo in Flash. Questo tutorial evidenzia gli usi più avanzati dei simboli.

Imparerai a:

 Creare simboli clip movie animati e simboli bottone

 Usare i campi di testo editabili nei simboli

 Assemblare un film

 Attaccare le azioni ai bottoni che controllano altro contenuto

 Pubblicare un film

Imparerai anche alcuni trucchi per l'animazione che troverai utili nei progetti futuri.
Prima di iniziare

Questo tutorial richiede una esperienza di base che appresa leggendo le sette lezioni incluse in Flash. Le lezioni sono disponibili scegliendo Help > Lessons. Assicurati di completare queste lezioni prima di avviare questo tutorial.

 Lesson 2, Drawing

 Lesson 3, Symbols

 Lesson 4, Layers

 Lesson 5, Text

 Lesson 6, Buttons

 Lesson 7, Sound

 Lesson 8, Animation

Visiona il film completato

Comincia dare uno sguardo al film finito per famializzare con ciò che sarà l'oggetto del tuo lavoro.

1 in Flash, scegli File> Open. Vai alla cartella dell'applicazione Flash, poi apri la cartella Tutorial e scegli Tutorial Finish.fla.

Non editare questo film, dal momento che è già finito. Editerai un'altra versione  durante il tutorial.

2 per avviare il film, scegli Control> Test Movie.
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Il film si apre con un'animazione che muove una fotografia al frigorifero e l'assicura con un magnete corona.

3 passa il cursore sui bottoni e osserva che essi si animano mostrando il titolo del contenuto quando li clicki. Clicka sui bottoni per vedere il contenuto supplementare.

4 quando finisci di esplorare il film, chiudi la finestra del film e il file Tutorial Finish.fla.

Puoi riferirti al file di Tutorial Finish.fla in tutto il tutorial per essere sicuro di aver eseguito correttamente il lavoro, o ritornare sulla traccia se ti sei perso.
Apri il file iniziale

1 in Flash, Scegli File> Open, e poi apri il file Tutorial Start.fla.

2 scegli File> Save As e salva il film con un nuovo nome del file così che da non alterare il file Tutorial Start.fla.

Se tu, o un altro utente, vuoi nuovamente usare il tutorial, è importante mantenere il file di Tutorial Start.fla originale.

3 Tutorial Start si deve aprire con la finestra Library mostrata. Se la finestra Library non è aperta, scegli Finestra> Library per aprirla.

Tutorial Start non è contenuto nel Timeline principale, ma la finestra Library contiene il lavoro base che avresti dovuto creare con le conoscenze acquisite seguendo le lezioni di Flash.
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Definisci le proprietà del film

È una buona idea cominciare a sviluppare un film dalla fine, pertanto iniziamo con la sua dimensione e background.

1 scegli Modify> Movie.

2 nel dialog box Movie Properties, setta le dimensioni del film a 550 x 400 pixels.

3 per Background, seleziona un colore arancio.
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4 clicka su OK per applicare le proprietà.

Il Palcoscenico è adesso arancio.

Crea un simbolo animato

Da Lesson 3, “Symbols,” hai imparato come lavorare con i simboli grafici e le istanze. I simboli possono includere anche le istanze di altri simboli e l'animazione. In questa sezione, creerai un simbolo che mostra la fotografia che si muove sulla porta del frigorifero all'inizio del film.

Inizia a creare un simbolo clip movie e altri simboli aggiungendoli poi ad esso. Un simbolo clip movie è come un film auto-contenuto che puoi mettere in un host movie come se fosse un solo oggetto. Puoi includere solo l'animazione e l'interattività come un film regolare.

Nota: Mentre lavori in Flash, spesso è utile recuperare (Undo) le tue azioni. Flash può recuperare (Undo) molte delle tue azioni recenti. Scegli Edit> Undo (o premi Control+Z (Windows) o Command+Z (Macintosh)) ripetutamente per ritornare attraverso sulle azioni recenti.

Scegli Edit> Redo (o premi Control+Y (Windows) o Command+Y (Macintosh)) per avanzare nelle azioni Undo.

Crea un simbolo clip movie

1 scegli Insert> New Symbol.

2 nel dialog box Symbol Properties, inserisci il nome “INTRO - ANIMATION.”

3 seleziona il Movie Clip come comportamento e poi clicka su OK.
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Flash cambia al modo movie-editing. Il modo symbol-editing assomiglia quasi esattamente al modo movie-editing. Osserva che il nome del simbolo che stai editando appare nell'angolo in alto a sinistra sul Timeline. Anche il nome ora appare nella finestra Library.

4 nel Timeline, doppio-click sul nome del layer esistente e inserisci “Photo.”
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5 trascina una istanza del simbolo INTRO - PHOTO dalla finestra Library e mettila sul punto di registrazione al centro del Palcoscenico come visualizzato nella figura seguente.
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Questo aggiunge una istanza del simbolo INTRO - PHOTO al simbolo INTRO - ANIMATION.

Usa i tasti freccia per muovere un simbolo di un pixel per volta. Premi Shift e usa i tasti freccia per muovere di dieci pixel per volta.

6 nel Timeline, seleziona la frame 20 nel layer Photo e scegli Insert> Keyframe.
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Poiche' vuoi che l'animazione inizi fuori dal Palcoscenico, devi definire una nuova posizione per INTRO - PHOTO nella prima frame.

7 seleziona il keyframe in frame 1.

8 muovi la istanza INTRO - PHOTO circa due pollici alla destra del punto di registrazione.

L'ubicazione esatta non è importante.
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Adesso che hai posizionato l'immagine per la prima frame, puoi creare un motion tween per far si che essa si muova sulla posizione del keyframe in frame 20.

9 Assicurati che il keyframe in frame 1 sia ancora selezionato, scegli Insert> Create Motion Tween. 
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Il Timeline dovrebbe adess orassomigliare a questo:

10 scegli Window > Controller per aprire il Controller e poi riavvolgere e avviare l'animazione per vedere ciò che hai fatto finora.

[image: image10.png]2] Scene 1

INTRO - ANIMATION

=50




La fotografia scivolerà da destra e si fermerà sul punto di registrazione del simbolo.

Una  Tween rotation e una dissolvenza

Adesso modifica il motion tween per fare la dissolvenza della fotografia e ruotarla quando si muove. Puoi farlo specificando un'alfa (trasparenza) settando 0 nel keyframe dove la fotografia apparirà prima, e settando il numero di rotazioni nel dialog box Tweening Properties.

1 Seleziona frame 1 nel layer Photo.

2 sul Palcoscenico, seleziona l'istanza INTRO - PHOTO e scegli Modify> Instance.

3 clicka sulla tab Color Effect nel dialog box Instance Properties e scegli Alfa dal pop menu Color Effect.
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4 muovi lo slider dell'Alfa a 0 e clicka su OK.

La fotografia diviene completamente trasparente (invisibile). Solo il bordo selezionato è visibile.

5 assicurati che il keyframe in frame 1 nel layer Photo sia ancora selezionato, scegli Modify> Frame, e poi clicka sulla tab Tweening.

6 scegli Clockwise (senso orario) dal Rotate pop-up menu, inserisci 1 nel box Times, e poi clicka su OK.
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7 usa il Controller per riavvolgere e avvia l'animazione.

Come il motion tween trasporta l'istanza del simbolo, ruota anche l'immagine e modifica i settaggi dell'alfa tra 0 e 100 per creare la dissolvenza della fotografia. 

In seguito, aggiungi il magnete corona in cima alla foto.

[image: image13.png][x]

BN TR BT



8 seleziona il keyframe sulla frame 20 nel layer Photo, e poi trascina una istanza del simbolo INTRO - CROWN dalla Library sopra la fotografia.

9 riavvolgi e avvia l'animazione per assicurarti che funzioni correttamente.

Aggiungi un'azione della frame per fermare l'animazione

Sebbene l'animazione che hai creato appaia ferma all'ultima frame mentre sei nel modo edit del simbolo, lavorerà in maniera diversa quando lo poni nel Timeline. I simboli clip movie fanno un loop finchè una volta avviato il film non crei un clip movie di arresto.

Aggiungi una frame action per creare questa fermata dell'animazione quando arriva all'ultima frame.

1 seleziona il layer Photo nel Timeline, e poi scegli Insert> Layer.

2 doppio-click sul nome del layer, e poi inserisci "Actions."

3 inserisci un keyframe in frame 20 nel layer Actions, e poi scegli Modify> Frame.
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4 clicka sulla tab Actions nel dialog box Frame Properties, clicka su + (più), e poi scegli Stop dal pop up menu Action. Clicka su OK.
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Hai completato adesso il simbolo INTRO - ANIMATION.
Crea i bottoni animati
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Lesson 6, “Buttons,” insegna come creare un bottone molto semplice. In questa sezione, creerai un bottone più complesso che si anima quando il mouse ci scorre sopra e mostra il testo con trasparenza. Per creare un bottone animato, metti un simbolo clip movie animato in una delle frames del bottone. Comincia a creare l'animazione.

1 doppio-click sull'icona per il simbolo BUTTON - HOME nella finestra Library per aprire il simbolo da editare.

Assicurati di clickare sull'icona del simbolo, non sul nome del simbolo altrimenti appena editi apparirà il nome del simbolo.

BUTTON - HOME è un bottone parzialmente completato incluso per risparmiarti alcuni passaggi.

2 scegli View> Show Frame per centrare il bottone nella finestra. Clicka sull'attrezzo magnificatore nel toolbox per allargare il bottone se necessario.
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3 nel Timeline, nomina il primo layer “Button.”

4 inserisci un keyframe su Over frame nel layer Button.

5 assicurati che il keyframe sula frame Over sia ancora selezionato, clicka dovunque sul Palcoscenico con attrezzo freccia per deselezionare l'immagine del bottone.

6 trascina una istanza del simbolo BOTTON - CROSS dalla Library al punto di registrazione nel simbolo BUTTON - HOME.
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BOTTON - CROSS è un simbolo clip movie che già contiene un'animazione di una croce che ruota. L'istanza BOTTON - CROSS dovrebbe essere al di sopra, precisamente sotto con la croce. Puoi usare i tasti freccia per muovere la selezione un pixel per volta.

Aggiungi trasparenza del testo al bottone

Prima, aggiungi il layer del testo trasparente al bottone.

1 nel Timeline, inserisci un nuovo layer e chiamalo “Trasparenza del Testo.”

2 seleziona il layer Text Trasparency nel Timeline e trascinalo sotto il layer Button nel Timeline.

Sistema i layers in modo che il contenuto del layer Text Trasparency appaia sotto il contenuto del layer Button.

3 crea un keyframe su Over frame nel layer Text Trasparency.
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4 seleziona il simbolo BUTTON - BACKGROUND nella Library, e poi trascinalo così che il suo lato sinistro sia sul punto di registrazione nel bottone.
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Adesso, fai in modo che il bottone background si fonda esattamente con qualsiasi background applicando ad esso un settaggio alfa.

1 con il BUTTON - BACKGROUND ancora selezionato nell'area di lavoro, scegli Modify> Instance.

2 clicka sulla tab Color Effect nel dialog box Instance Properties, e scegli Alfa dal pop menu Color Effect.

3 inserisci 50 come valore dell'Alfa, e clicka su OK.

4 assicurati che Over keyframe nel layer Text Trasparency sia ancora selezionato, clicka sull'attrezzo text.
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5 usa gli attrezzi modificatori del testo per scegliere Arial (Windows) o Helvetica (Macintosh), 18 punti, bold, italic.

6 inserisci la parola "Home" sul simbolo BUTTON - BACKGROUND. 

Non devi cambiare il contenuto di qualsiasi altra frame nel bottone.
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Duplica il bottone animato

Il bottone appena creato visualizza "Home" quando ci passi sopra. Adesso devi creare un altro bottone che mostri "Contact" quando ci passi sopra. Per risparmiare tempo, duplicherai il BUTTON - HOME e poi modificherai il suo testo.

1 nella Library, clicka sul simbolo BUTTON - HOME e poi scegli Duplicate dal menu  Library Options.

2 nomina il simbolo duplicato “BUTTON - CONTACT,” e clicka su OK.

3 doppio-click sul nuovo simbolo “BUTTON - CONTACT,” nella Library per editarlo.

Se necessario, Scegli View> Show Frame per centrare il bottone nella finestra e usare l'attrezzo magnificatore per allargare il bottone.
4 seleziona Over frame nel layer Text Trasparency e usa l'attrezzo del testo e i  modificatori per editare il testo e leggere “Contact.”
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Non potrai vedere ancora i bottoni che si animano perche' l'animazione clip movie non lavora nell'ambiente authoring.

Se vuoi vedere come lavorano i bottoni, scegli Edit> Edit Movie, trascina una istanza di BUTTON - HOME o BUTTON - CONTACT sul Palcoscenico, e poi scegli Control> Test Movie. Dopo aver avviato il film, chiudi la finestra del film e cancella l'istanza del bottone dal Palcoscenico.
Usa i campi del testo editabili

In Flash, puoi inserire i controlli interattivi e i campi testo editabili nei simboli. In questa sezione, aggiungerai la possibilità di inserimento dati al simbolo TEXT - CONTACT.

1 doppio-click sull'icona per il simbolo TEXT - CONTACT nella Library per aprire il simbolo da editare.

2 crea un nuovo layer nel Timeline e chiamalo “Data Entry.”

3 seleziona la prima frame nel layer “Data Entry” nel Timeline.
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4 con la prima frame nel layer “Data Entry” selezionata, clicka sull'attrezzo del testo e sul modificatore Text Field.
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5 Trascina sui campi editabili del testo per Nome, Email, e Commento.

Usa l'attrezzo freccia per aggiustare la dimensione e la posizione dei campi. Non è importante a questo punto ottenerli perfetti. Osserva che il manico di ridimensionamento quadrato su un campo del testo editabile è sull'angolo destro più basso del campo.

6 usando l'attrezzo freccia, seleziona il campo di testo Name e scegli Modify> Text Field per aprire il dialog box Text Field Properties.

7 inserisci "Name" nel box Variable e clicka su OK.

Flash assegna il contenuto inserito nel campo del testo editabile alla variabile della quale inserisci qui il nome. Puoi usare poi il valore della variabile nelle azioni.

8 ripeti i passi 6 e 7 per il campo di testo Email; chiama la variabile “Email.”

9 ripeti i passi 6 e 7 di nuovo per il campo di testo Commento; chiama la variabile “Comment”, e clicka su Multiline e sulle opzioni Word Wrap prima di clickare su OK.

Aggiungi il bottone Send

Adesso aggiungi il bottone Send al simbolo TEXT - CONTACT.
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1 assicurati che che la prima frame del layer input dei dati sia ancora selezionato, e poi trascina una istanza del simbolo BUTTON - SEND dalla finestra Library e mettilo sotto i campi editabili.

2 doppio-click sull'istanza del simbolo BUTTON - SEND per aprire il dialog box Instance Properties.

3 sulla tab Actions, clicka su + (più) e scegli Get URL dal pop-up menu.

4 scrivi un URL nel box sulla destra, scegli Send Using Get dal pop-up menu Variables, e poi clicka su OK.
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Questo manda i contenuti di tutte le variabili (il testo inserto nei campi editabili) all'URL specificato. In una vera applicazione, avresti bisogno di creare un valido  script CGI all'ubicazione URL per ricevere le informazioni, ma solo per imparare  puoi inserire qualsiasi URL e non importa se non c'è lo script CGI.

A questo punto, hai finito di creare i simboli per il film. Adesso sei pronto per usare i simboli che hai creato nel film principale.
Assembla il film
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Usando i simboli che hai creato finora, assemblare il contenuto del film è facile. Dopo averlo fatto, imparerai di più su come usare i layers per organizzare il contenuto di un film.

1 scegli Edit> Edit Movie.

2 chiama il primo layer nel Timeline “Fridge.”

3 trascina una istanza del simbolo BACKGROUND - FRIDGE dalla finestra Library sul Palcoscenico.

4 nel Timeline, inserisci un nuovo layer sul layer Fridge e chiamalo “Green Background.”

5 assicurati che il layer Green Background sia selezionato, e poi trascina una istanza del simbolo BACKGROUND - GREEN sul Palcoscenico.

Aggiungi i bottoni animati

Adesso, aggiungi i bottoni animati che hai creato.

1 inserisci un nuovo layer e chiamalo “Buttons.” assicurati che esso sia all'inizio del  Timeline.

Quando aggiungi i layers, dovrai poterli vedere tutti nel Timeline.
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2 trascina il bordo più basso della finestra del Timeline così che tutti i layers siano visibili.

3 seleziona il layer Buttons e trascina una istanza del simbolo BUTTON - HOME sul Palcoscenico.

Poiche' bottoni rispondono in modo diverso al mouse rispetto agli altri oggetti, hai bisogno di disabilitare i bottoni prima di poterli selezionare e di poter creare modifiche. Dopo che hai terminato di lavorare su bottoni, puoi abilitarli di nuovo.

4 scegli Control> Enable Buttons e assicurati che Enable Buttons non sia attivato.

5 seleziona l'istanza di BUTTON - HOME e muovilo in posizione.

6 assicurati che il layer Buttons sia ancora selezionato nel Timeline, e poi inserisci un istanza del simbolo BUTTON - CONTACT sotto l'istanza BUTTON - HOME sul Palcoscenico.
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7 per allineare i bottoni, clicka su BUTTON - CONTACT e premi il tasto Shift quando clicki BUTTON - HOME per selezionare ambedue i bottoni. Scegli Modify> Align e scegli l'opzione orizzontale allineato a sinistra.

8 scegli Control> Test Movie per vedere i bottoni animarsi quando scorri il mouse su di essi.

Dopo aver visto il film, chiudi la finestra prova per continuare a lavorare nel film.

Aggiungi il clip movie animato

Adesso aggiungi il clip movie INTRO - ANIMATION che hai creato.

1 inserisci un nuovo layer nel Timeline e chiamalo “Intro Animation.” Assicurati che esso sia in cima ai layers.

2 blocca gli altri layer per essere sicuro di lavorare solo nel layer “Intro Animation.”

3 trascina una istanza del simbolo INTRO - ANIMATION dalla finestra Library sul Palcoscenico.

Ricorda che l'immagine della fotografia è completamente trasparente nella prima frame del movie clip, così l'unica parte visibile di INTRO - ANIMATION è il punto di registrazione.
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4 muovi l'istanza INTRO - ANIMATION così che il suo punto di registrazione sia sul frigorifero.

Ricorda che l' animazione del clip movie non viene avviata in un ambiente authoring.

5 scegli Control> Test Movie per vedere il film con l'animazione. 

L'animazione gira solo la prima volta che il film viene avviato nella finestra  prova.

Per vedere l'animazione di nuovo, chiudi la finestra prova e scegli nuovamente Control> Test Movie.

Quando finisci di vedere l'animazione, chiudi la finestra prova per continuare a lavorare sul film.

Aggiungi il contenuto del testo ai layers

I bottoni che hai aggiunto sono pensati per fare apparire il contenuto del testo  nell'area verde sulla destra. Adesso sei pronto per aggiungere il contenuto del testo al film. 

1 inserisci un nuovo layer in cima al Timeline e chiamalo “Text Home.”
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2 seleziona il keyframe nella frame 1 del layer Text Home e trascina una istanza del simbolo TEXT - HOME sul Palcoscenico. Adatta il simbolo nell'area verde come mostrato in figura:
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3 per rendere più semplice vedere quello che stai facendo, clicka sulla colonna dell'Occhio del layer Text Home per nasconderlo prima di aggiungere il prossimo layer.[image: image34.png]IBOUT FRIDGE FASKIDNS
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Una X rossa appare per visualizzare che il layer è stato nascosto.

4 inserisci un nuovo layer in cima al Timeline e chiamalo “Text Contact.”

5 seleziona il keyframe nella frame 1 del layer “Text Contact” e trascina una istanza del simbolo TEXT - CONTACT sul Palcoscenico così che si adatti nell'area verde.

Usa le azioni per controllare il contenuto

Per creare i film interattivi settando le azioni, setta le istruzioni che vengono lanciate quando accade un evento specifico. Questi eventi possono essere quando il playhead arriva a una frame, o quando l'utente clicka su un bottone o preme un tasto sulla tastiera. Adesso aggiungerai le azioni ai bottoni per far sì che sia visualizzato un appropriato contenuto di testo quando vengono clickati i bottoni.

Modifica le istanze dei simboli del testo

Poiche' le azioni sono finalizzate solo ai simboli di clip movie, inizia modificando le istanze dei simboli del testo che hai aggiunto solo nei clip movie e dà loro i nomi. Nella prossima sezione usa questi nomi per identificare le istanze come obiettivi di un'azione. Comincia con l'istanza TEXT - CONTACT.

1 assicurati che il layer TEXT - CONTACT sia ancora selezionato nel Timeline, e poi un doppio-click sull'isatanza del simbolo TEXT - CONTACT sul Palcoscenico per aprire il dialog box Instance Properties.

2 clicka sulla tab Definition, e poi clicka su Movie Clip come il comportamento.

Osserva che appare un campo Instance Named sotto Instance Options.
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3 inserisci "Contact" come nome dell'istanza e clicka su OK.

Adesso, modifica l'istanza del simbolo TEXT - HOME.

1 nel Timeline, clicka sui controlli di visibilità per nascondere il layer Text Contact e mostrare il layer Text Home.

Ricorda che i controlli di visibilità per ciascuno layer è nella colonna sotto l'icona dell'occhio nel Timeline.

2 seleziona il layer Text Home nel Timeline, e poi un doppio-click sull'istanza

del simbolo TEXT - HOME sul Palcoscenico per aprire il dialog box Instance Properties.

3 clicka sulla tab Definition, e poi clicka su Movie Clip come il comportamento.

4 inserisci "Home" come nome dell'isatanza, e clicka su OK.

Aggiungi un'azione al bottone BUTTON - HOME

Adesso puoi aggiungere un'azione al bottone BUTTON - HOME che mostra il testo Home e nasconde il testo Contanct quando il bottone viene clickato.

I bottoni ancora sono disabilitati e pertanto puoi selezionarli e fare modifiche.

1 scegli Control> Enable Buttons e assicurati che Enable Buttons non sia attivato.

2 assicurati che il layer Buttons siano selezionati nel Timeline e aperti, poi un doppio-click sul bottone BUTTON - HOME sul Palcoscenico per aprire il dialog box Instance Properties. 

3 sulla tab Actions, clicka su + (più) e scegli Set Property dal pop-up menu.

4 scegli Visibility dal pop-up menu Set.
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5 clicka sul bottone alla destra del box Target e scegli Target Editor dal pop-up menu.
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6 nel Target Editor, doppio-click su Home per selezionarlo come target, e poi clicka su OK.

7 nel box Value sulla tab Actions, inserisci 1.

Adesso, aggiungi una seconda asserzione che nasconda il testo Conatact.

1 clicka su + (più) e scegli di nuovo Set Property dal pop-up menu.

2 scegli Visibility dal pop-up menu Set.

3 clicka sul bottone alla destra del box Target e scegli Target Editor dal pop-up menu.

4 nel Target Editor, doppio-click su Contact per selezionarlo come target, e poi clicka su OK.

5 nel campo Value, inserisci 0 (zero).

L'azione per BUTTON - HOME sembrerà come questa:

Se commetti un errore, puoi clickare sul bottone del meno (-) per rimuovere la linea selezionata nell'azione e poi ricreare l'asserzione. Puoi scegliere anche Edit> Undo.

6 clicka su OK il per chiudere il dialog box.

Aggiungi un'azione al bottone BUTTON - CONTACT

Adesso crea per il bottone BUTTON - CONTACT un'azione che mostri il testo Contact e nasconda il testo Home. 

1 doppio-click sul bottone BUTTON - CONTACT sul Palcoscenico per aprire il dialog box Instance Properties.

2 sulla tab Actions, clicka su + (più) e scegli Set Property dal pop-up menu.

3 scegli Visibility dal pop-up menu Set.
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4 clicka sul bottone alla destra del box Target e poi scegli Target Editor dal pop-up menu.

5 nel Target Editor, doppio-click su Contact per selezionarlo come target, e poi clicka su OK.

6 nel campo Value sulla tab Actions, scrivi 1.

Adesso, aggiungi una seconda asserzione che nasconda il testo Home.

1 clicka su + (più) e scegli di nuovo Set Property dal pop-up menu.
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2 scegli Visibility dal pop-up menu Set.
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3 clicka sul bottone alla destra del box Target e scegli Target Editor dal pop-up menu.

4 nel Target Editor doppio-click su Home per selezionarlo come target, e poi clicka su OK.

5 nel campo Value, inserisci 0 (zero).

L'azione per BUTTON - CONTACTsembrerà come questa:

6 clicka su OK il per chiudere il dialog box.

Aggiungi un'azione della frame

I layers nascosti nel Timeline non hanno effetto su contenuto quando lanci il film  fuori dell'ambiente authoring. Per nascondere sia Home che il testo Contact, quando il film comincia, aggiungi un'azione della frame al film.

1 crea un nuovo layer nel Timeline e chiamalo “Frame Actions.”

2 doppio-click sul primo frame nel layer “Frame Actions” per aprire il dialog box Frame Properties.

3 clicka sulla tab Actions e scegli + (più), e poi scegli Set Property dal pop-up menu.

4 Scegli Visibility dal pop-up menu Set.
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5 clicka sul bottone alla destra del box Target e scegli Target Editor dal pop-up menu.

6 nel Target Editor doppio-click su Home per selezionarlo come target, e poi clicka su OK.

7 nel campo Value sulla tab Actions, scrivi 0 (zero).

Adesso, crea un'asserzione nuova nell'azione copiando l'asserzione esistente.

1 premi Control+C (Windows) o Command+C (Macintosh) per copiare la prima asserzione nell'azione.
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2 premi Control+V (Windows) o Command+V (Macintosh) per incollare una copia dell'asserzione nella finestra.

Questo crea una copia della linea appena creata. Hai solo bisogno di modificare il target.

3 usa il Target Editor per modificare il target da Home a Contact.

L'azione sarà come questa:

4 clicka su OK il per chiudere il dialog box Frame Properties quando hai finito.

A questo punto, sei pronto col contenuto del film. Il tuo film sembrerà come l'esempio Tutorial Finish.fla.
Esamina il film

Adesso che il contenuto del film è finito, puoi esaminare il film per vedere tutte le sue caratteristiche.

1 scegli Control> Test Movie.
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2 mentre esamini il film, inserisci dei dati nei campi Contact. Inserisci più di una linea nel campo Comment per vedere le linee coperte dalle parole.

3 scegli Control> List Variables per visualizzare la finestra Output.

4 clicka su Send per vedere come lavorano le variabili.

La finestra Output mostra i dati che Flash invia al server.

[image: image45.png]


Un'applicazione funzionante richiederebbe azioni supplementari, come un'azione che cancella i campi dopo avere spedito i dati ma questo esempio ti dovrebbe dare una comprensione di base su come puoi usare Flash per spedire i dati a un server.

5 chiudi la finestra Output e poi chiudi la finestra nella quale il film sta scorrendo.

Adesso sei pronto a pubblicare il film.
Pubblica il film

Il contenuto del film è adesso finito. Per avviare il film in un browser, hai bisogno di esportarlo come un file Flash Player. Flash lo fa per te ogni volta che usi il comando   Test Movie.

Quando crei un sito web con Flash, hai bisogno spesso di includere molti files. In aggiunta a un film Flash, devi creare un documento HTML che apre in un browser e avvia il film Flash o visualizza gli altri disegni generati da Flash. Puoi anche volere  creare una versione del tuo film come GIF animato o un'immagine JPEG per visualizzare se il Flash Player non è installato.

Usa il comando Publish per esportare in tutti i formati supportati e creare un documento HTML con tutti i settaggio richiesti.

1 assicurati di aver chiuso la finestra separata nella quale stava girando il film e poi scegli File> Publish Settings.

2 sulla tab Formats, scegli Flash e HTML. Assicurati che l'opzione Use Default per i nomi dei files  sia selezionata.

Sebbene non si stia usando altri formati supplementari per questo tutorial, ecco dove puoi scegliere i formati supplementari come JPEG o QuickTime.

3 clicka sulla tab Flash.

Non hai bisogno adesso di modificare ognuna di queste opzioni, ma puoi averne bisogno più tardi per le tue opere. Puoi, per esempio, volere che i layers appaiano  dall'alto in basso invece che dal basso in alto come essi fanno in questo film.

4 clicka sulla tab HTML.

Ecco molti modi per controllare i film Flash con il codice HTML. I settaggi nel pannello HTML ti consentono di definire le scelte più comuni e utili, incluso la dimensione, il posizionamento, il colore, e la qualità del film.

Flash inserisce i settaggi che scegli in un documento maschera. Flash comprende molti documenti maschera contenenti il codice HTML per utili caratteristiche come l'individuazione del browser.

Per completare questo tutorial, segli una semplice maschera che non fa nulla eccetto che visualizzazione il film Flash specificato.
5 scegli Flash Only dal pop-up menu Template.

6 deseleziona l'opzione Loop.

Questo evita che il film si avvi continuamente.

7 clicka su Paused at Start così che nessuno segno di spunta appaia nel box di controllo.

Se lasci questa opzione attiva, il film non fa nulla finchè un'azione non l'avvia. Se vuoi che l'animazione si avvii appena la pagina viene caricata lascia inattiva questa opzione.

Non hai bisogno di modificare i valori di default per i settaggi HTML che rimangono.

8 clicka su Publish e poi clicka su OK per chiudere il dialog box Publish Settings e generare i files specificati.

Flash genera i nuovi files e li memorizza nella stessa cartella come il file del film.
Avvia il film in un browser

A questo punto il tuo lavoro in Flash è finito. Adesso puoi vedere come il film si avvia in un browser.

1 apri un browser come Netscape o Explorer.

2 apri il file HTML appena creato.

 In Netscape Navigator, scegli File> Open Page, e poi sfoglia per localizzare il file.

 In Internet Explorer, scegli File> Open, e poi sfoglia per localizzare il file.

Il file HTML è nella stessa cartella come il file del film e ha lo stesso nome come il film, con un estensione .htm o .html.

Il film verrà avviato solo nella finestra del browser come hai fatto quando hai usato  il comando Test Movie.
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